Subject: MAX Digest - 22 Sep 1999 to 23 Sep 1999 (#1999-281)
Date: Fri, 24 Sep 1999 00:00:09 -0400
From:
Automatic digest processor <LISTSERV@LISTS.MCGILL.CA>
Reply-To: MAX - Interactive Music/Multimedia Standard Environments <MAX@LISTS.MCGILL.CA>
To: Recipients of MAX digests <MAX@LISTS.MCGILL.CA>


There are 14 messages totalling 434 lines in this issue.

Topics of the day:

  1. pv problem
  2. ADB-USB and patch cords
  3. bug in Zicarelli's ascii
  4. Help the newbie! (2)
  5. Resonator Analysis software
  6. powerbooks
  7. Phasemod~ (before: mathematical problem)
  8. detonate can't load files - help!
  9. VXPocket
  10. Analysis software to program resonators~?
  11. PB1400 burnin up
  12. stereo groove~ looping?
  13. is it possible to...

----------------------------------------------------------------------

Date:Wed, 22 Sep 1999 18:59:19 -0400
From:Eric Singer <eric@ERICSINGER.COM>
Subject: pv problem

Has anyone experienced the following problem with pv?

Create a patcher ("Outer") with 'pv foo'. Create a subpatch inside it
("Inner"). Inside Inner, put another 'pv foo'. Save Outer.

Now, values in one 'pv foo' should be shared with the other. In my case,
they are not.

Close and reopen Outer. Now, everything works fine - values get shared.

Has anyone had this problem? (I'm using Max 3.5.9, OS 8.5, PB G3).

Eric

------------------------------

Date:Thu, 23 Sep 1999 10:26:55 +1000
From:David Rodger <auricle@ALPHALINK.COM.AU>
Subject: Re: ADB-USB and patch cords

"chriso" wrote:

>Several times I have heard of the lament of the lack of an ADB port on the
>B/W G3, and also of Apple's plans to rid themselves of this 'antiquated'
>technology. But I swear my G3 350 B/W has one built in! I plug in my old
>keyboard, wacom, etc. just to make sure I'm not way off base- no
>problem.... Maybe I bought some weird 'interim' model early on?

A friend of mine has one too. It seems to be a "panel" on the back which
has a USB port and an ADB port. Just as well, too, because the new
keyboards and mice are crap!

>If I've begun to draw a segmented patch cord and decide I want to stop, is
>there any way (save connecting to an object) that I can 'escape' the
>drawing process?


In MAX 2.5 and 3.0, you can click in the title bar of the patcher window
and the patch cord drawing aborts. I assume this is preserved in 3.5.x.

Regards, David

------------------------------

Date:Wed, 22 Sep 1999 19:39:37 -0400
From:Alejandro Cremaschi <cremasch@OAK.CATS.OHIOU.EDU>
Subject: bug in Zicarelli's ascii

Hello. I believe there's a bug in Zicarelli's ascii external.

The following patch works as expected when I useMaxFAT 3.5.8 or
MaxPlayFAT 3.5.8:

max v2;
#N vpatcher 50 40 450 340;
#P button 77 149 15 0;
#P number 225 179 35 9 0 0 0 3;
#P number 188 179 35 9 0 0 0 3;
#P number 149 179 35 9 0 0 0 3;
#P number 106 179 35 9 0 0 0 3;
#P number 142 87 35 9 0 0 0 3;
#P newex 141 148 74 196617 unpack 0 0 0 0;
#P newex 141 119 38 196617 ascii 4;
#P connect 2 0 0 0;
#P connect 0 0 7 0;
#P connect 0 0 1 0;
#P connect 1 0 3 0;
#P connect 1 1 4 0;
#P connect 1 2 5 0;
#P connect 1 3 6 0;
#P pop;

BUT, if I try using the 68K version of both Max and MaxPlay it just
doesn't work anymore. ascii outputs nothing. This is really inconvenient,
since I use this object a lot in a patch I'm creating for a 68K Mac.

I'm using a version of ascii created on Nov. 3 1997. Is there a newer
version of this object that fixes this bug?

Any help will be appreciated.

Thanks. Alejandro

------------------------------

Date:Wed, 22 Sep 1999 21:14:03 -0700
From:David Zicarelli <zicarell@SOUNDFLOWER.COM>
Subject: Re: Help the newbie!

Alejandro Cremaschi <cremasch@OAK.CATS.OHIOU.EDU> writes:

>When I create a stand-alone application with Max's Application Installer
>v.1.1, all the "Kind" fields of all my MAX files everywhere are
>changed to the name of the stand-alone app I just created, rather than
>saying the usual "Max 3.5.8 document".
>
>How do you prevent this from happening?

  1. Use ResEdit (Get Info for "MyApp") to change the modified date
    of your application to something older than the desired
    version of Max.
  1. Use a creator that isn't "max2" (again, use ResEdit to change

this) for your application.

David Z.

------------------------------

Date:Thu, 23 Sep 1999 10:21:45 +0100
From:Vincent Puig <Vincent.Puig@IRCAM.FR>
Subject: Resonator Analysis software

YES ! There is an analysis model for the "modeles de r=E9sonnance",
(resonance model implemented by CNMAT in MSP), developped by Ircam in the
new version of Diphone available on the next Forum Ircam cdrom issued in
November for the Forum workshops in Columbia University (19, 20, 21 of
November).

>
>Date:
Wed, 22 Sep 1999 10:42:30 +0200
>From:
Roald Baudoux <roald.baudoux@BRUTELE.BE>
>Subject: Analysis software to program resonators~?
>
>Hi Maxers,
>
>Does anyone knows which software could be useful to analyse a sound and
>extract a list of frequencies in order to program the resonators~ object
>from CNMAT?
>
>Thank you in advance.
>
>Roald Baudoux
>

Vincent Puig
IRCAM
1 place Igor Stravinsky
75004 Paris
=46rance
Tel: 01 44 78 49 59
=46ax: 01 44 78 15 40
email : puig@ircam.fr

------------------------------

Date:Thu, 23 Sep 1999 09:11:32 EDT
From:ACDCVC@AOL.COM
Subject: powerbooks

In a message dated 9/23/99 4:02:02 AM, LISTSERV@LISTS.MCGILL.CA writes:

<< i don't know about supercollider + protools but i use a PB1400c as my main
max machine. it has always worked flawlessly and, touching wood, never
crashed under its current config (max 3.5.9, OS 8, OMS 2.3.7). oh for
another serial port though..... >>

How fast is it? I am looking for the fastest powerbook without USB ports to
run MAX.

------------------------------

Date:Thu, 23 Sep 1999 16:02:38 +0200
From:Manuel Poletti <Manuel.Poletti@IRCAM.FR>
Subject: Re: Help the newbie!

Launch a resource utility like ResEdit; from the 'get info' window', open
your app and change its 'max2' creator to something like 'MYAP' or
whatever.Then restart the Mac and rebuild the desktop: your Max files
should kindly retrieve their original "kind", wich is the name of the last


Max or MaxPlay application that you installed on your HD.
_M

>--GNNIMKQUXRZbCECFQKNWVJQGeYTMaM
>Date:
Wed, 22 Sep 1999 13:08:22 -0400
>From:
Alejandro Cremaschi <cremasch@OAK.CATS.OHIOU.EDU>
>Subject: Help the newbie!
>MIME-Version: 1.0
>Content-Type: TEXT/PLAIN; charset=US-ASCII
>
>Hi. I'm sure this one is pretty basic...
>
>When I create a stand-alone application with Max's Application Installer
>v.1.1, all the "Kind" fields of all my MAX files everywhere are
>changed to the name of the stand-alone app I just created, rather than
>saying the usual "Max 3.5.8 document".
>
>How do you prevent this from happening?
>
>Thanks...
>Alejandro

------------------------------

Date:Thu, 23 Sep 1999 18:17:19 +0200
From:jvkr <jvkr@KONCON.NL>
Subject: Phasemod~ (before: mathematical problem)

Recently Eric Lyon said here:
>You could try my phasemod~ object under:
>
>http://arcana.dartmouth.edu/~eric/MAX/
>
>Lots of nasty harmonics for filter-sweeping joy.

Completely true.
Eric, one question: when the frequency (left inlet) is extremely low, and
the modulation index (right inlet) is a sine with a high frequency, the
signal (outlet) extinguishes with a cycle depending of the extremely low
frequency (left inlet). This could be avoided by adding another phasemod~
which is out of phase half a cycle. Is it possible to do this? I noticed
that everytime Max/MSP is started, all oscillators initiate (indeed) to
phase zero.

Thanks in advance
Johan

------------------------------

Date:Thu, 23 Sep 1999 14:03:19 +0000
From:Jeff Mann <jefman@UTCC.UTORONTO.CA>
Subject: detonate can't load files - help!

Hi - hoping someone can help me with this, otherwise I've got a rather
large disaster coming as I brilliantly explain to the composer I'm
working for that I may miss this weekend's deadline for a working
version since I have to start all over from scratch using nato+0.55... :-)

There seems to be a bug in detonate when opening a midi sequence file
with the "read midifilename.seq" command. The first time I give the
command, I can hear the disk being accessed, but the sequence doesn't
load. If I try it again, I get "error: detonate: can't open
midifilename.seq". Each time I do this, Max's free memory reading goes
down by 1k.

It makes no difference whether I give a full path:filename, one relative
to Max, or just a filename by itself that's in the search path. None of


them load. The seq object is able to load all of these with no problem.

If I use the "read" command by itself, a file dialog opens and detonate
loads the file - all is well (this is how I've been testing it so far).
BUT - if I send "read midifilename.seq", and then afterwards I try to
load it manually with "read", I get the same error message and it won't
load. I can still load other sequences manually, just not any that I've
previously tried to load with a filename argument.

Such files remain unloadable until I quit Max. They even become
unloadable by other objects such as seq.

Any ideas?

Say, maybe this would be a good time to add that "locate" command to
detonate too :-) (works the same as "start", but with a millisecond
offset into the file).

Thanks... <Jeff
--
Jeff Mann - Information Consumer ___O___O__= -- >
"Tapping one's toe in time with a piece of music while sitting on
a modern carpet can induce +/-10 volt potential change on a can of
Spam five feet away."- The Amateur Scientists' Bulletin

------------------------------

Date:Thu, 23 Sep 1999 14:33:53 -0500
From:Darwin Grosse <ddg@EXECPC.COM>
Subject: Re: VXPocket

I got a lot of questions about the VXPocket, but I was unfortunately busy
being chased around the country by Hurricane Floyd, then getting prepped for
AES...

Some quick answers, first. Latency of the VXPocket (as measured by the
Latency patcher) is between 140 and 150 ms. Much greater than I thought,
and higher than it would seem. There is an ASIO driver for it, but when I
try to use it with the pre-release ASIO system, I get a "Error - can't use
2016 bufsize yet".

Oh, well... More when this gets ironed out.

[ddg]
Darwin Grosse

------------------------------

Date:Thu, 23 Sep 1999 08:30:09 -0500
From:"Timothy A. Place" <tplace@CCTR.UMKC.EDU>
Subject: Re: Analysis software to program resonators~?

>Date:Wed, 22 Sep 1999 10:42:30 +0200
>From:
Roald Baudoux <roald.baudoux@BRUTELE.BE>
>Subject: Analysis software to program resonators~?
>
>Hi Maxers,
>
>Does anyone knows which software could be useful to analyse a sound and
>extract a list of frequencies in order to program the resonators~ object
>from CNMAT?
>
>Thank you in advance.
>
>Roald Baudoux

Try using fiddle~. The 5th outlet in particular may be useful to you, an


argument to the object will tell it how many "partials" it you want it to
detect. It will then give you a packed list of "partial" number,
frequency, and amplitude for each.

Good luck!
-Tim


____________________________
./`./`Timothy A. Place
./`./`tplace@cctr.umkc.edu
./`./`www.frontiernet.net/~place1/tap/

------------------------------

Date:Fri, 24 Sep 1999 00:24:20 +0100
From:"jim.y-wood" <jim.y-wood@VIRGIN.NET>
Subject: PB1400 burnin up

>>I just heard of a
>>cheap price on Powerbook 5300s (and I think some 1400s too). Could I get
>>a quick response on how these machines are for Max and, given a G3 upgrade
>>card, MSP as well?
>
> I have a 5300. Fine for Max. Nearly worthless for MSP. To my knowledge,
> nobody makes a processor upgrade for the 5300 (unlike the 1400).
>
Unfortunately all the PB1400 upgrades have gone nobody makes them anymore,
as I found out much to my chagrin just as i finally got round to try
ordering one - all gone. Especiallly as Vimage went bust ( although they
might come back in the future but who knows if they'll still support this
model). There may be one from Japan - "Interware Power booster1400" but hard
to come by, not exported, also being phased out??
Still, I've used a 1400 for msp and SuperCollider v1 and at 22000kHz or
11000kHz just about works but not exactly pro audio if steem comes out the
sides you know when to notpush it.


Jim

------------------------------

Date:Thu, 23 Sep 1999 21:21:51 -0500
From:"Timothy A. Place" <tplace@CCTR.UMKC.EDU>
Subject: stereo groove~ looping?

Hi all,

I have just run across an odd problemthat I can't solve - I was wondering
if anyone could give me an answer or duplicate the problem:

When using a single channel of audio, groove~ works as advertised.
<however>
When an argument is given to specify stereo output, groove~ will not loop
(though it does play its one time through in stereo!)

I found this true even with the groove~ help patch if I simply added the
argument "2" as a second groove argument.

Am I nuts?
Powerbook G3-292MHz,128MB-RAM,OS 8.1, latest Max and MSP.

Thanks in advance,
-Tim


____________________________
./`./`Timothy A. Place
./`./`tplace@cctr.umkc.edu
./`./`www.frontiernet.net/~place1/tap/

------------------------------

Date:Thu, 23 Sep 1999 22:36:54 -0400
From:Michael Carlito <mlito@ALBANY.NET>
Subject: is it possible to...

Hello,
The question is, is it possible to create a split screen with max and
have two seperate QT files running at the same time or at different
times? Maybe someday I'll get the hang of Max. I hope I'm not too
old by then.

thanks
mike
Chance favors the prepared mind

------------------------------

End of MAX Digest - 22 Sep 1999 to 23 Sep 1999 (#1999-281)
**********************************************************